Jump to content

System Requirements of Tiberian Sun Reborn +


Guest noddynod443
 Share

Recommended Posts

Guest noddynod443

Hi all,

      What are the recommended system requirements of all W3D hub games?

I'm using windows xp and remember reading somewhere that the minimal OS was vista...

Before I upgrade to vista I wanted to known if that was true. 32-bit os or 64-bit?

 

Link to comment
Share on other sites

Hello there and welcome to W3D-Hub!

You would be better off running windows 7 64-bit with service pack 1 installed. Vista would be a bad move for many reasons (and I think the minimum requirements have now changed to win7 sp1 as well). However, if you are that far behind (sorry to word it like that, but you are on XP) I might recommend also checking your system to be sure that you can even run windows 7. Many XP-era machines can do it, but you need to be sure. Furthermore, it may be the best route to just go ahead and get windows 10, since the cost would be the same (assuming your PC is up for it).

Feel free to post your system specs here and we'll have a look!

Link to comment
Share on other sites

Welcome guest, what Einstein said is good advice to listen to, as an outdated OS would leave you quite vulnerable as any back doors that haven't been patched, could be readily exploited by those with evil intent. Aside from all of that though, in my personal opinion, Tiberian Sun: Reborn is currently the less demanding of the two that are currently out.

Link to comment
Share on other sites

7 hours ago, ganein14 said:

Welcome guest, what Einstein said is good advice to listen to, as an outdated OS would leave you quite vulnerable as any back doors that haven't been patched, could be readily exploited by those with evil intent. Aside from all of that though, in my personal opinion, Tiberian Sun: Reborn is currently the less demanding of the two that are currently out.

It is yes, as it still runs on the 4.x scripts branch, as well as some other factors that make it less demanding. And while this version of the game itself technically still could run on windows XP (I think), you will need at least windows 7 service pack 1 for the launcher to run and be able to install it.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...