Jump to content

Running the Launcher on Windows 7 - Enabling TLS1.2


danpaul88
 Share

Recommended Posts

If you are using Windows 7 you may have problems connecting to our backend services using the Launcher. This is because, by default, Windows 7 does not support TLS 1.2, which is a stronger encryption protocol that many modern websites use, ours included.

Updating to a modern operating system that is still supported by Microsoft is the best option, however if for some reason you are unable or unwilling to do so, you can forcibly enable TLS 1.2 support in Windows 7 via the registry by setting the following options;

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\SecurityProviders\SCHANNEL\Protocols\TLS 1.2\Client]
"DisabledByDefault"=dword:00000000

If you are unsure how to do this, I suggest following this guide. Note that you must have all recommended Windows Updates installed or this may not work.

You can read more about this topic on Microsoft's website here and here

Link to comment
Share on other sites

  • 1 month later...
  • 1 month later...

i had a problem with script.dll i was told enable TLS 1.2 THAT didnt help i found a repair in launcher which fixed it, sense this update  i dont see any games its blank  so cant repair anything. i did all that was said i still get the same problem launcher was working fine before the update. I think something in update is not allowing my pc to login to launcher cause it worked fine before the update...

 

w3dhub issue.jpg

TLS 1.2.jpg

w3dreg.jpg

Edited by MaDMaxNXC
Link to comment
Share on other sites

On 8/8/2021 at 8:47 PM, MaDMaxNXC said:

i had a problem with script.dll i was told enable TLS 1.2 THAT didnt help i found a repair in launcher which fixed it, sense this update  i dont see any games its blank  so cant repair anything. i did all that was said i still get the same problem launcher was working fine before the update. I think something in update is not allowing my pc to login to launcher cause it worked fine before the update...

 

w3dhub issue.jpg

TLS 1.2.jpg

w3dreg.jpg

Any ideas @ danpaul88 ?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...