Jump to content

APB Crashing on launch after update


Dudeman2700
 Share

Recommended Posts

RA:APB has always worked just fine for me, as with all W3D hub games. After the most recent update, I am unable to join the server. Upon running the .exe or trying to join through the launcher, I get this message:

https://ibb.co/Jnn1S9B

 

I'm using an Alienware m17 R4 laptop, 9 years old now I think, Intel i7-4710 quad-core @ 2.5ghz, 16 GB RAM, 64-bit OS Windows 7. Radeon HD 8970M graphics card but it died a couple years ago so I've been making do with the onboard graphics, aka "Intel(R) HD Graphics 4600", which has been working just fine with lowered graphic settings on the games I normally play--Warcraft, Starcraft, Renegade/W3dHub and Renegade X.

 

Anyway never had this problem before, not sure why I can't connect, any help is appreciated, thanks!

 

Edit: This is the error message linked above:

 

Custom scripts.dll engine code has stopped working.

Problem signature:
  Problem Event Name:    BEX
  Application Name:    game.exe
  Application Version:    5.0.0.0
  Application Timestamp:    617327cc
  Fault Module Name:    ucrtbase.DLL
  Fault Module Version:    10.0.14393.2247
  Fault Module Timestamp:    5adc1a6f
  Exception Offset:    00087fd4
  Exception Code:    c0000417
  Exception Data:    00000000
  OS Version:    6.1.7601.2.1.0.256.48
  Locale ID:    4105
  Additional Information 1:    843d
  Additional Information 2:    843dbcb32bf2b015ce5f4cd1bd0f2492
  Additional Information 3:    0263
  Additional Information 4:    02639132c28a1e46b8c25edbb10ea577

Read our privacy statement online:
  http://go.microsoft.com/fwlink/?linkid=104288&clcid=0x0409

If the online privacy statement is not available, please read our privacy statement offline:
  C:\Windows\system32\en-US\erofflps.txt
 

Edited by Dudeman2700
Link to comment
Share on other sites

Also found this in the errors.txt:

--------------------------------------------------
2021/12/04 14:21:26
Application version: 0.13.0.4 W3D Hub Launcher.exe
--------------------------------------------------

[WARNING] Failed to load image from URI
    Exception (WebException) The remote server returned an error: (404) Not Found.

    Stack Trace;
   at System.Net.HttpWebRequest.EndGetResponse(IAsyncResult asyncResult)
   at System.Threading.Tasks.TaskFactory`1.FromAsyncCoreLogic(IAsyncResult iar, Func`2 endFunction, Action`1 endAction, Task`1 promise, Boolean requiresSynchronization)
--- End of stack trace from previous location where exception was thrown ---
   at System.Runtime.ExceptionServices.ExceptionDispatchInfo.Throw()
   at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)
   at W3DHub.Backend.WebClientImplementation.<>c__DisplayClass1_0.<<GetAsync>b__0>d.MoveNext()
--- End of stack trace from previous location where exception was thrown ---
   at System.Runtime.ExceptionServices.ExceptionDispatchInfo.Throw()
   at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)
   at W3DHub.UIToolkit.Media.MediaProvider.<LoadImageFromUriImplAsync>d__2.MoveNext()

--------------------------------------------------
2021/12/04 14:58:32
Application version: 0.13.0.4 W3D Hub Launcher.exe
--------------------------------------------------

[WARNING] Failed to load image from URI
    Exception (WebException) The remote server returned an error: (404) Not Found.

    Stack Trace;
   at System.Net.HttpWebRequest.EndGetResponse(IAsyncResult asyncResult)
   at System.Threading.Tasks.TaskFactory`1.FromAsyncCoreLogic(IAsyncResult iar, Func`2 endFunction, Action`1 endAction, Task`1 promise, Boolean requiresSynchronization)
--- End of stack trace from previous location where exception was thrown ---
   at System.Runtime.ExceptionServices.ExceptionDispatchInfo.Throw()
   at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)
   at W3DHub.Backend.WebClientImplementation.<>c__DisplayClass1_0.<<GetAsync>b__0>d.MoveNext()
--- End of stack trace from previous location where exception was thrown ---
   at System.Runtime.ExceptionServices.ExceptionDispatchInfo.Throw()
   at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)
   at W3DHub.UIToolkit.Media.MediaProvider.<LoadImageFromUriImplAsync>d__2.MoveNext()

--------------------------------------------------
2021/12/04 15:02:21
Application version: 0.13.0.4 W3D Hub Launcher.exe
--------------------------------------------------

[WARNING] Failed to load image from URI
    Exception (WebException) The remote server returned an error: (404) Not Found.

    Stack Trace;
   at System.Net.HttpWebRequest.EndGetResponse(IAsyncResult asyncResult)
   at System.Threading.Tasks.TaskFactory`1.FromAsyncCoreLogic(IAsyncResult iar, Func`2 endFunction, Action`1 endAction, Task`1 promise, Boolean requiresSynchronization)
--- End of stack trace from previous location where exception was thrown ---
   at System.Runtime.ExceptionServices.ExceptionDispatchInfo.Throw()
   at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)
   at W3DHub.Backend.WebClientImplementation.<>c__DisplayClass1_0.<<GetAsync>b__0>d.MoveNext()
--- End of stack trace from previous location where exception was thrown ---
   at System.Runtime.ExceptionServices.ExceptionDispatchInfo.Throw()
   at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)
   at W3DHub.UIToolkit.Media.MediaProvider.<LoadImageFromUriImplAsync>d__2.MoveNext()

 

And when navigating to my folder where the "crash dumps" are supposed to be, this is what the folder contains:

https://ibb.co/2vgy3Rn

 

 

Link to comment
Share on other sites

That log file is from the launcher itself, it's not related to the game not starting properly. I'd suggest trying to repair the game using the option in the launcher to verify the files are all correct.

Could also look in event viewer to see if there's any more information there, since without the crash dump it'll be hard to debug for the APB team

Link to comment
Share on other sites

1 minute ago, danpaul88 said:

That log file is from the launcher itself, it's not related to the game not starting properly. I'd suggest trying to repair the game using the option in the launcher to verify the files are all correct.

Could also look in event viewer to see if there's any more information there, since without the crash dump it'll be hard to debug for the APB team

I have tried the "Repair Installation" button 4 times now, each time it has said "Installation Completed Successfully".

It crashes whether joining the server or trying to boot up single player. Interim Apex and all of the rest of the servers are working just fine. Only the APB startup is crashing.

In the "crash dump" folder, shown in the photo in the post above, the contents of the files are as follows:

_asset_errors.txt

Failed to load hierarchy 'ShatterPlanes1'
Failed to load animation 'IF_BACK01.IF_BACK01'
Warning: Mesh 'MZ_V_GDI_MEDTNK.MUZZLEFLASH02' tries to use multi-material (per-polygon) with a sorted (alpha blended) material. This will be rendered with a static sort level of 20 instead and potentially display incorrectly. Please split the transparent parts into a separate mesh.
Warning: Mesh 'MZ_RIFL3.MUZZLEFLASH' tries to use multi-material (per-polygon) with a sorted (alpha blended) material. This will be rendered with a static sort level of 20 instead and potentially display incorrectly. Please split the transparent parts into a separate mesh.
Failed to load animation 'S_A_HUMAN.H_A_V10A'
Failed to load 'o_em_apc'
Failed to load animation 'S_B_HUMAN.H_B_F1J0'
Failed to load animation 'S_B_HUMAN.H_B_F2J0'
Failed to load 'F_CM_M162'
Failed to load animation 'F_GM_M162.F_GA_M162_IDLE'
Failed to load animation 'F_GM_M162.F_GA_M162_FIRE'
Failed to load animation 'F_GM_M162.F_GA_M162_RELOD'
Failed to load animation 'F_GM_M162.F_GA_M162_RLDEN'
Failed to load animation 'F_SKELETON.F_HA_M162_RLDEN'
Failed to load animation 'F_SKELETON.F_HA_PIST_IDLE'
Failed to load animation 'S_B_HUMAN.H_B_V10A'
Failed to load 'F_CM_MLAW'
Failed to load animation 'F_GM_MLAW.F_GA_MLAW_IDLE'
Failed to load animation 'F_GM_MLAW.F_GA_MLAW_FIRE'
Failed to load animation 'F_GM_MLAW.F_GA_MLAW_RELOD'
Failed to load animation 'F_GM_MLAW.F_GA_MLAW_RLDEN'
Failed to load animation 'F_SKELETON.F_HA_MLAW_RLDEN'
Failed to load animation 'S_B_HUMAN.H_B_A0J1'
Failed to load animation 'S_B_HUMAN.H_B_A0J0'
Failed to load animation 'S_B_HUMAN.H_B_A0L1'
Failed to load animation 'S_B_HUMAN.H_B_F1J1'
Failed to load animation 'S_B_HUMAN.H_B_F2J1'
Failed to load animation 'S_B_HUMAN.H_B_F1J2'
Failed to load animation 'S_B_HUMAN.H_B_F2J2'
Failed to load animation 'S_B_HUMAN.H_B_F2L2'
Warning: Mesh 'MZ_RIFL3.MUZZLEFLASH' tries to use multi-material (per-polygon) with a sorted (alpha blended) material. This will be rendered with a static sort level of 20 instead and potentially display incorrectly. Please split the transparent parts into a separate mesh.
Failed to load 'F_CM_AK47'
Failed to load animation 'F_GM_AK47.F_GA_AK47_IDLE'
Failed to load animation 'F_GM_AK47.F_GA_AK47_FIRE'
Failed to load animation 'F_GM_AK47.F_GA_AK47_RELOD'
Failed to load animation 'F_GM_AK47.F_GA_AK47_RLDEN'
Failed to load animation 'F_SKELETON.F_HA_AK47_RLDEN'
Failed to load 'F_CM_TOZZ'
Failed to load animation 'F_GM_TOZZ.F_GA_TOZZ_IDLE'
Failed to load animation 'F_GM_TOZZ.F_GA_TOZZ_RELOD'
Failed to load animation 'F_GM_TOZZ.F_GA_TOZZ_RLDEN'
Failed to load animation 'F_SKELETON.F_HA_TOZZ_RLDEN'
Failed to load 'F_CM_DRAG'
Failed to load animation 'F_GM_DRAG.F_GA_DRAG_IDLE'
Failed to load animation 'F_GM_DRAG.F_GA_DRAG_FIRE'
Failed to load animation 'F_GM_DRAG.F_GA_DRAG_RELOD'
Failed to load animation 'F_GM_DRAG.F_GA_DRAG_RLDEN'
Failed to load animation 'F_SKELETON.F_HA_DRAG_RLDEN'
Failed to load 'e_rockblast'
Failed to load 'F_CM_SBIN'
Failed to load animation 'F_GM_SBIN.F_GA_abin_IDLE'
Failed to load animation 'F_GM_SBIN.F_GA_abin_FIRE'
Failed to load animation 'F_GM_SBIN.F_GA_abin_RELOD'
Failed to load animation 'F_GM_SBIN.F_GA_abin_RLDEN'
Failed to load animation 'F_SKELETON.F_HA_abin_RLDEN'
Warning: Mesh 'O_FLAGDEFRED.O_FLAGPOLE_RED' tries to use multi-material (per-polygon) with a sorted (alpha blended) material. This will be rendered with a static sort level of 20 instead and potentially display incorrectly. Please split the transparent parts into a separate mesh.
Warning: Mesh 'O_FLAGATTRED.O_FLAGPOLE_RED' tries to use multi-material (per-polygon) with a sorted (alpha blended) material. This will be rendered with a static sort level of 20 instead and potentially display incorrectly. Please split the transparent parts into a separate mesh.
Warning: Mesh 'O_FLAGDEFBLUE.O_FLAGPOLE_BLUE' tries to use multi-material (per-polygon) with a sorted (alpha blended) material. This will be rendered with a static sort level of 20 instead and potentially display incorrectly. Please split the transparent parts into a separate mesh.
Warning: Mesh 'O_FLAGATTBLUE.O_FLAGPOLE_BLUE' tries to use multi-material (per-polygon) with a sorted (alpha blended) material. This will be rendered with a static sort level of 20 instead and potentially display incorrectly. Please split the transparent parts into a separate mesh.
Warning: Mesh 'MZ_V_GDI_MEDTNK.MUZZLEFLASH02' tries to use multi-material (per-polygon) with a sorted (alpha blended) material. This will be rendered with a static sort level of 20 instead and potentially display incorrectly. Please split the transparent parts into a separate mesh.
Warning: Mesh 'MZ_RIFL3.MUZZLEFLASH' tries to use multi-material (per-polygon) with a sorted (alpha blended) material. This will be rendered with a static sort level of 20 instead and potentially display incorrectly. Please split the transparent parts into a separate mesh.
Warning: Mesh 'O_FLAG.O_FLAGPOLE' tries to use multi-material (per-polygon) with a sorted (alpha blended) material. This will be rendered with a static sort level of 20 instead and potentially display incorrectly. Please split the transparent parts into a separate mesh.
Failed to load 'S_TRNSFRMR01'
Failed to load 'F_CM_M162'
Failed to load 'o_em_apc'
Failed to load 'e_rockblast'
Failed to load 'F_CM_M60'
Failed to load animation 'F_GM_M60.F_GA_M60_IDLE'
Failed to load animation 'F_GM_M60.F_GA_M60_RELOD'
Failed to load animation 'F_GM_M60.F_GA_M60_RLDEN'
Failed to load animation 'F_SKELETON.F_HA_M60_RLDEN'
Failed to load animation 'NULL.NULL'
 

 

_shaders.txt

error X3501: '': entrypoint not found

error X3501: '': entrypoint not found

error X3501: '': entrypoint not found

error X3501: '': entrypoint not found

error X3501: '': entrypoint not found

error X3501: '': entrypoint not found

error X3501: '': entrypoint not found

error X3501: '': entrypoint not found

error X3501: '': entrypoint not found

error X3501: '': entrypoint not found

error X3501: '': entrypoint not found

error X3501: '': entrypoint not found

error X3501: '': entrypoint not found

error X3501: '': entrypoint not found

error X3501: '': entrypoint not found

error X3501: '': entrypoint not found

error X3501: '': entrypoint not found

error X3501: '': entrypoint not found

error X3501: '': entrypoint not found

error X3501: '': entrypoint not found

error X3501: '': entrypoint not found

error X3501: '': entrypoint not found

error X3501: '': entrypoint not found

error X3501: '': entrypoint not found

error X3501: '': entrypoint not found

error X3501: '': entrypoint not found

error X3501: '': entrypoint not found

error X3501: '': entrypoint not found

error X3501: '': entrypoint not found

error X3501: '': entrypoint not found

error X3501: '': entrypoint not found

error X3501: '': entrypoint not found

error X3501: '': entrypoint not found

error X3501: '': entrypoint not found

error X3501: '': entrypoint not found

error X3501: '': entrypoint not found

error X3501: '': entrypoint not found

error X3501: '': entrypoint not found

error X3501: '': entrypoint not found

error X3501: '': entrypoint not found

error X3501: '': entrypoint not found

error X3501: '': entrypoint not found

error X3501: '': entrypoint not found

error X3501: '': entrypoint not found

error X3501: '': entrypoint not found

error X3501: '': entrypoint not found

error X3501: '': entrypoint not found

error X3501: '': entrypoint not found

error X3501: '': entrypoint not found

error X3501: '': entrypoint not found

ff_template.fx(384,2-32): warning X3206: implicit truncation of vector type
ff_template.fx(385,2-33): warning X3206: implicit truncation of vector type

ff_template.fx(384,2-32): warning X3206: implicit truncation of vector type
ff_template.fx(385,2-33): warning X3206: implicit truncation of vector type
error X3501: '': entrypoint not found

ff_template.fx(384,2-32): warning X3206: implicit truncation of vector type
ff_template.fx(385,2-33): warning X3206: implicit truncation of vector type

error X3501: '': entrypoint not found

error X3501: '': entrypoint not found

ff_template.fx(384,2-32): warning X3206: implicit truncation of vector type
ff_template.fx(385,2-33): warning X3206: implicit truncation of vector type

ff_template.fx(384,2-32): warning X3206: implicit truncation of vector type
ff_template.fx(385,2-33): warning X3206: implicit truncation of vector type
error X3501: '': entrypoint not found

ff_template.fx(384,2-32): warning X3206: implicit truncation of vector type
ff_template.fx(385,2-33): warning X3206: implicit truncation of vector type

error X3501: '': entrypoint not found

error X3501: '': entrypoint not found

error X3501: '': entrypoint not found

error X3501: '': entrypoint not found

error X3501: '': entrypoint not found

error X3501: '': entrypoint not found

error X3501: '': entrypoint not found

error X3501: '': entrypoint not found

error X3501: '': entrypoint not found

error X3501: '': entrypoint not found

error X3501: '': entrypoint not found

error X3501: '': entrypoint not found

error X3501: '': entrypoint not found

error X3501: '': entrypoint not found

error X3501: '': entrypoint not found

error X3501: '': entrypoint not found

error X3501: '': entrypoint not found

error X3501: '': entrypoint not found

error X3501: '': entrypoint not found

error X3501: '': entrypoint not found

error X3501: '': entrypoint not found

error X3501: '': entrypoint not found

error X3501: '': entrypoint not found

 

_texture_manager.txt

"multisplash01.tga" not found.
"RA_RockTrap_map.dds" not found.
"" not found.

 

 

The rest of the files appear to be randomly saved chat logs from random games. The "save" folder is empty.

 

 

Link to comment
Share on other sites

So, this is a bit annoying because the game doesn't even get to its crash reporter to produce a memory dump for us to analyze, which leaves us with basically no information whatsoever. You're going to have to tell Windows to automatically generate crash dumps when this game crashes. The process is documented here: https://docs.microsoft.com/en-us/windows/win32/wer/collecting-user-mode-dumps

I have made two reg files for you to automate this process (enabling/disabling the crash dumps). disable game exe crash dumps.regenable game exe crash dumps.reg

After enabling the crash dumps and trying to run the game you should be able to see a .dmp file appear in the folder %LOCALAPPDATA%\CrashDumps (just paste this into your explorer address bar or manually navigate to C:\Users\<yourusername>\AppData\Local\CrashDumps). If you could upload that file (or a zipped version, it compresses really well), we can at least try to figure out what is going on.

Link to comment
Share on other sites

Okay so I feel like I've seen this crash before. It's very bizarre since all it tries to do is create/rewrite the commands.txt file in the documents folder but somehow it can't open the file and crashes. From the dates of the files in the screenshot I can see it was able to open engine.cfg in the same folder just fine. I have absolutely no idea why this would happen. You could try deleting commands.txt and see whether that helps.

In case that does not work, I've put in a check so it shouldn't crash anymore when this fails, but I can't guarantee that it won't crash somewhere else later from a similar error because I simply have no idea why this would fail and I'm not very keen on trying to find all the places where we access any files in the engine to try and safeguard them. I don't think I'm allowed to distribute the fix to you individually and you'll have to wait for a new APB patch to be released if deleting the file doesn't help.

Link to comment
Share on other sites

Just a thought here, it may or may not be related. Check the permissions and ownership of the folder in question as well as the files inside. Im on mobile currently or I would send you this myself, but you can google and find a quick reg edit that will add a "Take Ownership" option to your context menu. Use it to take ownership of the folder and see if it changes anything.

 

Also, does your user have administrative priveledges? And are you running the game/launcher elevated or no? Currently the launcher elevates automatically so that it can update games, and because of this, the game processes are also spawned as admin processes. Sometimes this can do weird stuff, and sometimes it actually doesnt happen, which again causes weird stuff (permissions). Its rare, but its a thing so I just thought I would mention it.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...