Jump to content

script.dll problem


MaDMaxNXC
 Share

Recommended Posts

here is the error.log file,  this only happens on w3dhub APB 3.5 officail server. i tried to take a SS of the popup i push prtscn i go the MSpaint and ther paste is grayed out so it must not be allowed to take a SS. i found crashdump file but cannot upload it on here its bigger then what is allowed to upload..

ty

errors.log

Edited by MaDMaxNXC
i found crashdump file
Link to comment
Share on other sites

  • 2 weeks later...

Sorry, I somehow missed this thread.

1. The error log is from the W3D Launcher and it says it can't establish a secure connection. If the launcher still does not work, please update your Windows.
https://support.microsoft.com/en-us/topic/update-to-enable-tls-1-1-and-tls-1-2-as-default-secure-protocols-in-winhttp-in-windows-c4bd73d2-31d7-761e-0178-11268bb10392

2. The crash dump is from Interim Apex, not APB. Unfortunately the dump doesn't seem to contain any useful information. Does this happen consistently?

Link to comment
Share on other sites

everytime i click on that server. the 1.5 server  and all the other servers work fine. only one that dont work is 3.5 server that is when i get the a pop up saying, "Custom script.dll engine code has stop working" and there is a button at bottom right says close program...

my pc is up todate on windows i check for new update there are none  and im still getting same script.dll problem...

it works on w3dhub TRS 1.5 fine then.  there something  in w3dhub  APB 3.5 SERVER  that is blocking the script or connections cause why would i be able to play on 1.5 server. i thought it might been because of it is in Europe but that's not the case. so its must be something in the scripting part that blocking my id or blocking something i see 52 players on that server and i am that only one that cannot play on it that's puzzling to me. I HAVE 150 TO 180MB interent connection. if all this info helps any.

Edited by MaDMaxNXC
Link to comment
Share on other sites

@MaDMaxNXC Hi

Lets do a simple test to rule some things out. Since you are trying to play APB delta, let us first make sure that your game even runs correctly. Can you run it in single player mode? On the Games tab, select APB and you should see the blue Single Player button.

Depending on what happens, this will tell us more about how to continue.

Also, your APB crashdumps are in a similar place to the one that you uploaded, just in a folder called APB (or apb-release I believe).

 

Link to comment
Share on other sites

OK ill try single player.  i click on  games page  window i have C&C renegade, ECW,  Interm Apex and 2 others  C&C games that are not renegade  related . in games  page window I dont see APB in games  page,  Games page is default page when i first  open W3DHUB launcher, f that is what your saying...  

also  I see W3DHUB APB 3.5 offical i dont see in server list,   "delta" i mention this in previous reply all other servers in server browser work only W3DHUB 3.5 offical i get the "Custom script.dll engine code has stop working"  .   when i click on this my screen goes black like game is starting then 1 to 2 sec a pop up opens up with a all white displayer behind pop up...

Edited by MaDMaxNXC
Link to comment
Share on other sites

On 2/14/2021 at 4:50 PM, Dghelneshi said:

Are you trying to connect to the APB server from a Renegade client? APB hasn't been playable from Renegade in a long time. It is a standalone mod on a version of the engine that is incompatible with the original. You need to install APB from our launcher to play APB.

No Im using W3D HUB Launcher, I have tried that a while ago and popup said need to install W3D HUB Launcher so i did just that months ago...

 

Link to comment
Share on other sites

On 2/17/2021 at 12:44 PM, Einstein said:

Screenshots might help us understand what issue you are experiencing.

I have mention why I cant upload a SS of the pop up  at top of this thread. error  IDK who made the "error  pop up windows"  but  it does not allow me to take  a SS. Although I did added on this thread what pop up said this is what it says,,,, Custom script.dll engine code has stop working             

 So something is causing the drivers to stop working probably some coding issue  its not allowing or letting my renegade pass through. like I said all other servers work fine so its not my renegade the problem is on the  APB server . .  It shouldn't matter what renegade package I bought at all as long as my renegade is up to date which it is. I thought it might of been the 4.7 scripts i had to install but i downgraded to the previous scripts and i get same error..  

ty

regards

Chris

 

Link to comment
Share on other sites

21 minutes ago, MaDMaxNXC said:

I have mention why I cant upload a SS of the pop up  at top of this thread.

Totally forgot about that bit, sorry. But if we could have some of your crashdumps, and have clarity on whether or not the game runs in single player mode, that will help us in trying to figure this out.

Link to comment
Share on other sites

On 2/19/2021 at 11:11 AM, Einstein said:

Totally forgot about that bit, sorry. But if we could have some of your crashdumps, and have clarity on whether or not the game runs in single player mode, that will help us in trying to figure this out.

i added one crash dump but ill go see if there is more. 

 

On 2/19/2021 at 7:38 PM, Dghelneshi said:

Have you tried adding the APB game exe as an exception to your anti-virus program (particularly AVG seems to dislike it for unknown reasons)?
If that doesn't solve it, what hardware (CPU, GPU) and operating system are you running on?

No I havent tried that but I will do that, but where do i fine this Apb game.eve if ur talking about it being in task manager its not only running proccess for renegade is game.exe and W3D HUB launcher  ok for some odd reason crashdumps are not being made now i have tried player on the APB server 3 times today no crashdump was created last crashdump i found was on 2/19/2021 ill compress it and upload it. someone asi me for my computer specs ill upload a dxdiag file aswell. ok both are uploaded ill try to find out why no crashdumps arent being created.

I been searching on the web about this issue i have and i found someone else was getting same script error iv been getting and its from the same program W3DHUB LAUNCHER only thing that is different is he was playing C&C red alert.. here is link ..

maybe this might be more help.

I really appreciate your guys trying to  help?solve this issue.

 

 

crashdump.20210219-162039-r8610-n1.dmp.7z DxDiag.txt

Edited by MaDMaxNXC
Link to comment
Share on other sites

On 2/19/2021 at 11:11 AM, Einstein said:

Totally forgot about that bit, sorry. But if we could have some of your crashdumps, and have clarity on whether or not the game runs in single player mode, that will help us in trying to figure this out.

I can play on any other game: browser games,  non browser game,. installed games, and all the other renegade  servers are playable only one i cant play is APB so it not my computer  the APB server or  W3DHUB Launcher   is  blocking my connection or something....

If this crashdump is not from the APB SERVER then the  crashdumps from APB SERVER  are not being made  thats why are are hard to find them because there are none. why arent  any .dmp files being made up?  W3DHUB Launcher should make crashdumps maybe devs or who ever fix's   bugs need to start there I think the launcher disconnecting me before i even get to the game thats probably why their arent any crashdumps,  I looked in windows event it has  error logs made up from W3DHUB Launcher.    Dghelneshi   tells me to update my windows to TSL 1.2 I have them all installed even have  all 3 SSL  versions installed.  I dont understand what browser TSL.1.1-1.2 Has anything to do with launching APB Server.

I can't do scripting/programming but I can fix computers/windows. 
 

regards

Chris

Edited by MaDMaxNXC
Link to comment
Share on other sites

Please understand that we are trying to help. The questions and suggestions we are giving are not random. We are trying to identify a pattern that would reveal the problem, or at least get us closer to finding it.

If D told you to install a TLS update, then I recommend that, as D is a programmer and likely knows much more about what could be wrong than I do.

Some computers will run all other games fine, as they should. But sometimes a small random issue can prevent a game or type of game from running, even on a computer that is physically capable. The smallest thing can be out of place to cause this, we just have to work together to find out what it is.

The game server will not block your connection unless you have been banned, and even then IT WILL CONNECT for long enough to display a message to you saying that you have been banned, and disconnect only after you press "ok". You have NOT been banned however, and your client is not connecting at all, so it is not a blocking issue there.

Similarly, the launcher does not block any connections - it only creates them, by launching games. It does not possess the capability to do anything more.

The games all generate crashdumps - normally. The launcher is not crashing, so it does not need to generate a dump in this case, neither does the server, as it is not crashing either.

It is uncommon for a game to crash without creating a dump. That in itself is useful information, and is likely what led D to wonder about an antivirus software potentially blocking the game from running at all, because it suggests that the game is crashing before the code that creates the dump files is able to be executed. Since that code is near to the beginning, a crash so early in the program's runtime usually means that it never really ran at all, which indicates that something (such as an antivirus software) may have prevented it. That is not the only possibility, just one that is usually easy to identify, which is probably why it came up first.
 

3 hours ago, MaDMaxNXC said:

maybe devs or who ever fix's   bugs need to start there

That would be us. We are trying to understand what is happening and why. Perhaps a one of us can have a look at your system via teamviewer or other remote software?

Link to comment
Share on other sites

6 hours ago, Einstein said:

If D told you to install a TLS update, then I recommend that, as D is a programmer and likely knows much more about what could be wrong than I do.

This was for the error in the launcher log. The entire thread has been a bit confusing. I said "if the launcher still does not work", then try that update. Since the launcher clearly works, there is no issue here.

I'm still betting on anti-virus.

Link to comment
Share on other sites

4 hours ago, Dghelneshi said:

This was for the error in the launcher log. The entire thread has been a bit confusing. I said "if the launcher still does not work", then try that update. Since the launcher clearly works, there is no issue here.

I'm still betting on anti-virus.

Ahh I see.

Max, I just realized that we dont know what version of Windows you are running.

APB requires Windows 7 with service pack 1, or Windows 8/8.1 or Windows 10 in order to run at all. Reborn and IA and all others will still run on older operating systems however.

What version are you using?

Link to comment
Share on other sites

16 minutes ago, Einstein said:

Ahh I see.

Max, I just realized that we dont know what version of Windows you are running.

APB requires Windows 7 with service pack 1, or Windows 8/8.1 or Windows 10 in order to run at all. Reborn and IA and all others will still run on older operating systems however.

What version are you using?

DxDiag shows Win7 SP1. Hardware is very old but barely above minimum target for 5.0 so it should run.

Link to comment
Share on other sites

  • 2 weeks later...

nvm i got it to work. i thought the in the w3dhub launcher under game page Red Alert  game was like renegade i thought it was C&C red alert game. so i never clicked on it and i was ever told to click on that game and it didn't say anything about APB.  ANY HOW i was just browsing through launcher in game page and  i missed click on red alert  i didn't even know where i was at for a couple mins i was looking at all the avatars and that's when i seen ABP  So i looked at a few more avatars and ABP was under several avatar pics so i did a repair install and it fix it.

i only recall being told to repair the interim apex  nothing else and that didn't help at all.

if files was corrupted why wasn't .dmp files created

 

anyhow its fixed now it just would of been so much easier if i have known red alert was ABP  i would repaired it long ago.

 

Dghelneshi 

I thank you a lot for doing your best to help me with this issue and also i thank the others that tried helping aswell

 

thank you all

 

regards

 

Chris

 

 

 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...