Jump to content

Installing tools for W3D modding


Recommended Posts

Author: moonsense715, ChopBam

Skill level: 1


Hi and welcome to the tutorial that will get you started with modding/building in the W3D engine.


This is merely a tutorial to set your tools up and running so you can start modding right away.

Let's get to the point now since that's why you came here.




Game Asset Creation

To create content for the game, you will need a modeling software.



Option 1: Gmax-RenX


The smallest, simplest, free software out there is gmax 1.2.

Unzip the file, start up gmax12.exe and hit "Setup". After self-extraction is completed, go through the installation process.


Since Discreet/Autodesk no longer supports Gmax it is impossible to get a working Identification Code online.

(They were always free in the past, they just sent the code to you in an e-mail, but that does not work anymore.) Therefore, there is a legal workaround that lets you "activate" Gmax.

Double-click on Autodesk.reg to add it to your registry keys.

(Feel free to read the Read_Me.txt file for more information about this.)


W3D tool pack - RenX

To make Gmax compatible with W3D, you need to install RenX from the Renegade Public Tools.

Run the installer and go through the process. You can leave everything ticked, but:

If you do not have C&C Renegade, the Level Editor that comes with Renegade Tools will not work properly.


Now start up RenX from the installed RenegadePublicTools for the first time and choose a Display Driver. Feel free to use HEIDI Software Z Buffer and hit OK, since you can change this later if necessary anyway.

Shortly after RenX starts up, the software will get recolored into a shade of green.

You have finished installing GMax for W3D modding.




Option 2: 3ds Max 8 - for advanced users


Instead of using Gmax, you can also try 3ds max 8 for 30 days. It has better keyboard shortcut support and is a better choice if you plan to model and unwrap buildings, vehicles and weapons.

Run Setup.exe to install it and run as a trial to try it out.

  • If there are any errors about AcGe16.dll missing, you can probably find the file in C:\Program Files (x86)\Common Files\Autodesk Shared, and you can move it to your new 3DS Max folder (usually C:\Program Files (x86)\Autodesk\3dsMax8)


- Setting up 3ds Max for W3D

For using Max 8 to set up and export W3D content, you have to install the following:

  • DirectX 2008 (even if you have a newer one)
    • -Run directx_nov2008_redist.exe
    • -Extract the .cab files to any folder
    • -Run DXSETUP.exe, which will be in the folder you extracted the .cab files to
  • 3DS Max Service Pack 3
    • -Run Setup_3dsMax8_SP3.msp
  • W3D Scripts for 3DS Max
    • -Copy the contents of W3D_Scripts.zip to your Max 8 directory (usually C:\Program Files(x86)\Autodesk\3dsMax8), as this contains the w3d plugins and the w3d importer
    • -For ATI video card users: drop the contents of ati.zip into your max directory

Now start up Max. When you launch for the first time, it will pop up with a "Graphics Driver Setup" window. Try using OpenGL as this is the best driver when it works. Otherwise, Software should do the trick.

  • If you need to change the driver, from within the program you can go to Customize -> Preferences -> Viewports then click on Choose Driver and choose Software this time
  • If you can't get into 3DS Max at all and you need to change the driver, go to Start -> Programs -> Autodesk -> Autodesk 3ds max 8 -> Change Graphics Mode to access the popup again, and choose Software

Windows 10 Only: viewport freezing fix

  • Copy the 3dsmax.exe in your executable folder.
  • Paste it back in the same folder.. you will have a 3dsmax - copy.exe
  • Change your desktop shortcut to run the -copy.exe version.
  • Set the desktop shortcut to run as administrator
    • Many people have reported this problem as being fixed when they follow these steps

Windows 10 Only: fixing autobak

  • Autobak (the process of the program auto backing up your work) may not work natively on Windows 10 due to the way permissions now work inside Program Files. You'll need to take control and possibly ownership of your Autobak folder inside C:\Program Files (x86)\Autodesk\3dsMax8 to allow 3ds max to write files to that directory

You have to add the W3D Tools to your Utilities tab. Click Utilities (hammer icon), click Configure Button Sets and scroll down to Westwood Tools. Drag W3D Tools over to an empty button and hit OK.




After all that, your 3ds Max 8 is now ready to create and export content into file formats the W3D engine works with.





Level Editor

Level Editor is where you manage your game content. You set up the physics for objects, give them health, armor, weapons, speed. For specific maps you set the game objective, place special script zones, edit the sun position along with the clouds, and so on.

Every W3D game has its specialized editor. For a properly working Level Editor, you MUST have an installed W3D game on your computer.


- Renegade Level Editor

The Renegade Public Tools installer will have installed an old (non-scripts) version of LevelEdit.  This version works but lacks many features.

The latest version of LevelEdit is available in the TIberian Technologies Mod Tools:

TT downloads page

Replace your copy of LevelEdit with the one in the zip.  Note: this version of LevelEdit will only work if you also have Tiberian Technologies scripts installed.


- TS:Reborn Level Editor

To install the TSR Editor, just download the file below and follow the instructions in the "How to install LE.txt" file.

Download TSR LE



Having a modeling software and Level Editor installed, you can go ahead and start creating/modding stuff in the W3D engine!



Other tools


W3D View

This tool is used mostly to view W3D models, create emitters/sound emitters and create LOD for objects.

Download W3D View



This is used to open files such as .mix or .pkg extension maps and mods as well as always.dat. You can extract files from them with this tool.

Download RenegadeEx

Edited by Veyrdite
Veyrdite: add link to TT mod tools (updated LevelEdit)
Link to comment
Share on other sites

  • 4 years later...

Since Discreet/Autodesk no longer supports Gmax it is impossible to get a working Identification Code online.

Just wanted to let you know that you can still get a working Identification Code online through TurboSquid website here:


Just create an account if you didn't have one already in the past.

Then copy and paste your code.


Link to comment
Share on other sites

  • 8 months later...
  • 1 year later...
  • 2 years later...


When at the Level Editor setup part, I am having trouble getting anything to open past the window pop-up where I can choose/open a .pkg -- once I click a mod.pkg to load, the actual editor itself doesn't load at all.  I am just stuck at my desktop.

Here is what I have:

I have bought the 'Command & Conquer Ultimate Collection' from the 'EA App' software (The same method shown at: https://cncnet.org/buy#ultimate-collection on how to buy it)

I have installed C&C Renegade, Scripts 4.8 (https://www.tiberiantechnologies.org/files/scripts-4.8.exe), and also the RenegadePublicTools (https://multiplayerforums.com/files/file/80-renegade-public-tools/) which contains the Level Editor.

From the 'TT downloads page' link I clicked and downloaded the "Tools ZIP     tools-4.8.zip - MD5: 74f885b646c1bec43821b87ea3b1ea11" file.

I replaced the original LevelEdit exe with the one from this 'Tools ZIP' file.


And this is where I run into the trouble I mentioned.  After trying several times, I tried Jerad's post of adding a registry entry just as he had in the screenshot (adding a InstallPath registry entry into the Level Edit folder/registry area).  This did not seem to change anything, and Level Edit continues not loading as before.

Are there any broken links or updated steps I need to do if I have C&C Renegade through the 'Command & Conquer Ultimate Collection' method?  Thanks for any help!  :)

Edited by Tersvog Cvoosc
Link to comment
Share on other sites

If you're running 64-bit, the path to the proper registry entry may be slightly different. Did the Westwood Studios folder pre-exist or did you have to add a new one? If it didn't already exist, try looking in Wow6432Node under Software.

Link to comment
Share on other sites

Hmm... not sure if the Westwood Studios folder was there before (do you mean before I installed RenegadePublicTools/Level Editor?), I installed C&C Renegade sometime in 2023 (maybe around March-April) and haven't gone into the registry for anything related to Renegade/Level Edit/Westwood Studios until today.  I didn't have to (manually) add any new folders named 'Westwood Studios' though.  :raise: Hmm...

Checking for a folder Wow6432Node was successful, but there is no Software folder listed underneath. 

Thanks for the response. :cheers:

Edit/Update: Success!  Thanks to additional help from ChopBam and elbappotsnU in combination with following instructions in this thread (moonsense715 and Jerad2142 posts), the Level Editor is now working:

Windows 11, 64-bit
Scripts 4.8 installed
Level Editor doesn't have empty folders in the Presets Tree/Window, there are now the default presets for soldiers, vehicles, props, etc
Level Editor .exe from the Scripts 4.8 'Tools(http://www.tiberiantechnologies.org/downloads)' download is present
Using an install of C&C Renegade from the 'Command & Conquer Ultimate Collection' purchased via the EA App software

The main fix seemed to be going into the regedit to define + create an InstallPath string/entry as Jerad mentioned, but making sure for Windows 64-bit systems (I was on Windows 11), the registry path to use is actually going to be 'Computer\HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Westwood\Renegade', this should get the Level Editor to load in normally with default presets from Renegade automatically loaded in!

Edited by Tersvog Cvoosc
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...