Jump to content
Sign in to follow this  
trunkskgb

Map Crash (Renegade)

Recommended Posts

So question, I'm trying to "revive" C&C Ravine. This map doesn't seem to work with recent TT updates. I have not played this map dating back to almost 2004. I thought if I converted it back with Level Redit, I could fix whatever issue it's causing. I attached the crash dump file. Can anywhere look at it and tell me why this map won't work?

ravine.zip

Share this post


Link to post
Share on other sites

With the exception of Jonwil, I don't think anyone here can really help on the Renegade front.

But, I can think of a few possible crashes.

Are to attempting a recovery via importing the mix file in some way (Edit: yes you are, via some program called Level Redit that I never used)? Chances are, you are using conflicting scripts in the project folder that are not compatible with newer versions.

But in truth, if you are not using the original level edit project, then you should be looking to start anew instead. You can always extract the art files from the mix and then import these into 3DS, be aware however that you will need to apply a lot of fixes as W3D import is a last-resort method in the event of losing art source files.

Beyond that, importing mix files into level edit typically has a very large range of crash risks and other issues, so to pinpoint the exact cause, well, your only hope is Jonwil. I'm just letting you know you should consider a clean slate to save yourself a world of trouble!

Edited by Raap

Share this post


Link to post
Share on other sites

Thank you Raap!

I'll try out a few things starting by looking at the scripts.

I'm taking an old Renegade map, C&C Ravine (hasn't worked in years, and I haven't played it in even longer), and trying to fix it. Level Redit does "unpack" the mix file and gives you the w3d file, the Level Edit scene files, LDB, LDS,LDD...etc, and any textures from the map as well. I've used this before on two other maps, but the other maps weren't crashing, they just had some minor issues, script zones, waypaths, etc. Ravine simply crashes when you try to run it, and I want to try and fix that.

I didn't see any scripts file from the unpack, nor did I add any to the mix file. I won't be able to take a look at again until later tonight, or perhaps this weekend. 

I was the error/s crashes were more descriptive though lol.

Share this post


Link to post
Share on other sites
7 hours ago, trunkskgb said:

Level Edit scene files, LDB, LDS,LDD...etc, 

(...)

I didn't see any scripts file from the unpack, nor did I add any to the mix file.

Edit: I sort of assumed your project crashes on loading, but to be clear, does your LE crash as you select the project in the little dialog box? Or does the crash occur when you try to load the .lvl?

Edit2: If you actually meant your MIX crashes IN GAME, which is actually not very common unless you break something weird, then I pretty much guarantee it is a faulty preset instance. In this case check your instances in LE for dubious entities, delete what you do not know.

---

Sounds like the most likely issue then is a dubious preset instance, in the older Level Edits such a thing causes an 'corruption' of sorts.

Unfortunately there is only one man who can delve under the hood, and than is W3D Wizard and Solver of Raap Problems; Jonwil.

So you got two three choices:

  • Read my above edits about preset instances if your crash occurs either in-game or upon loading the .lvl.
  • Contact Jonwil on these forums and hope he has time to look into your issue.
  • Start from a clean project using the latest 4.x.x tools and scripts and use W3D import as a foundation of your level rebirth.

I recommend the latter in this particular case because even if Jon fixes your one crash, chances are there is a boatload of other broken things because of how old these files are.

Choice is yours, good luck either way!

 

Edited by Raap

Share this post


Link to post
Share on other sites

If you don't want to touch the level in gmax/3dsmax, then don't use W3D Import. Just start a new mod package and add the existing W3D map file as temp under Terrain again. You just need to place the building controllers, PTs, spawners, waypaths, and tib script zones, plus whatever else I've forgotten. You can also spice it up with weapon spawners, music and anything you can think of.

Share this post


Link to post
Share on other sites

I looked at the posted crashdump and whats happening is that the level loading code is trying to load a sound object that exists in the level. This sound object then looks for a sound file named "frank_klepacki_-_no_mercy_remix.mp3" (without the quotes) and either can't find the file or is unable to load it properly.

 

Share this post


Link to post
Share on other sites

Well.... like always I'm glad I posted here. What other maps are you hiding @dblaney1? I always had a feeling you "tweaked" C&C Dawn Raid, and now I'm right. :)

@Raap & @moonsense715 So what you're telling me is that after I use Level Redit to unlock the level edit files, and W3D file, that I should just start up a new mod package in LE, and start from there? That actually does make more sense then having to sift through all the problems you can with duplicate objects and such. I will do this moving forward. Adding building controller's and etc. doesn't bother me. Thanks!

 

@jonwil As always, thank you man! 

I used level edit and tried to open 2 other maps that I took from level redit. C&C Steppe & C&C Radiation. The LE objects loaded, but no Terrain when I opened LE. I'll try a new mod package as suggested above later, but is this a separate issue? Screen shots below

Radiation.thumb.jpg.b024376d2ea09df7c6dc2cdb9908cea1.jpg

Steppe.thumb.jpg.b3ea017685fcaee60c33cb385a6cd1b5.jpg

Share this post


Link to post
Share on other sites

In this case the LE work is preserved, keep it, don't start a new mod package! Just find the map W3D file, add it as a new temp terrain preset, then click "Make".

If that doesn't work:
In the case of Renegade maps, I've barely ever seen a map where the terrain and buildings are not in 1 w3d file. So either LevelRedit could not restore the map objects, or the buildings are indeed in a separate w3d file from the map w3d file. Can you check how many w3d files you have, that seem to be terrain or buildings?

Share this post


Link to post
Share on other sites

One of these days I should use the fact that I know everything there is to know about the format of .lvl files, .lsd files and .ldd files and write something that is like levelredit but without all the suck...

 

Share this post


Link to post
Share on other sites

@moonsense715 Yeah I think I have all the w3d files that I need that would be the terrain. I'll try temping it soon and seeing if that fixes it!


@jonwilThat would be great, but aside from myself and Dblaney, how much use would it get?  I know I would because I'm in the process of trying to revive old maps at the moment. 

Share this post


Link to post
Share on other sites

Also, another map I want to fix is Paradox Harbor. Take a look at the video below. All the building exteriors are missing. Is that an easy fix?
 

 

Share this post


Link to post
Share on other sites
1 hour ago, trunkskgb said:

Also, another map I want to fix is Paradox Harbor. Take a look at the video below. All the building exteriors are missing. Is that an easy fix?
 

Whoa it seems like someone decided to messed up vis REAL BAD. There is two possibility for this, either the VIS is generated and he removed the vis in w3d file from the map when if he re-export the map for whatever reason, I kinda have this issue before.

Or

He auto generate vis and stop it before its completion. I think you can just discard vis and see if the map is shown in Level Editor.

You can regenerate vis but it will probably leave your PC for 12 hours + or more depending on your quality proficiency in vis generation and how things work.'

I am pretty sure is a VIS issue because you can walk on the platform and it seems physical and camera collisions were there.

As for texture I am not sure, if the texture were in the mix file it should be there but if it wasn't is hard to fix, unless you know what your doing with it.

 

btw is way is hard to find proper scale and proportionate map.

Long story short

Vis is like negotiating with the devil even or those who has experience with it you may have a hard time to tackle it.

But if you manage to get it right it makes the map run very smooth and performance optimize.

Share this post


Link to post
Share on other sites

Pushwall tells me all the time he loves creating VIS sectors, especially in open view levels with both naval and air units enabled. Literally the best times in his life.

...

Fingers crossed that maybe one day, following a successful Mammoth implementation, we can have a skilled individual work on creating a more automated culling system. No idea if that could ever be done for Level Edit though, but what do I know right!

Anyhow, back on the topic of reviving old maps. I applaud your enthusiasm @trunkskgb, I personally have a life time burnout of fixing old stuff as I have done so a lot for APB over the years (especially in ~2007-2008). I'm just happy to work on new things now.

Share this post


Link to post
Share on other sites
21 hours ago, Raap said:

Pushwall tells me all the time he loves creating VIS sectors, especially in open view levels with both naval and air units enabled. Literally the best times in his life.

...

He was the one who stated : "Basically VIS is like dealing with the devil." 😁

I love to deal with VIS but it can be very annoying almost all the time. And yes I SUFFERED from VIS lol. That is why 1 map like my Infinite Isle took 8 months to polish the VIS. Redo again and again.

Share this post


Link to post
Share on other sites

The whole concept of VIS on W3D is backwards to begin with. It is designed for a 'ship it and never touch it' development mentality but none of the W3D projects operate under that mentality as stuff keeps changing on all levels as development perpetually continues.

Share this post


Link to post
Share on other sites

Vis also fails hard when proxied assets change since all the precalculated stuff is now based on the older assets

Share this post


Link to post
Share on other sites
On 8/3/2018 at 2:08 PM, Kaskins said:

Whoa it seems like someone decided to messed up vis REAL BAD. There is two possibility for this, either the VIS is generated and he removed the vis in w3d file from the map when if he re-export the map for whatever reason, I kinda have this issue before.

Or

He auto generate vis and stop it before its completion. I think you can just discard vis and see if the map is shown in Level Editor.

You can regenerate vis but it will probably leave your PC for 12 hours + or more depending on your quality proficiency in vis generation and how things work.'

I am pretty sure is a VIS issue because you can walk on the platform and it seems physical and camera collisions were there.

As for texture I am not sure, if the texture were in the mix file it should be there but if it wasn't is hard to fix, unless you know what your doing with it.

 

btw is way is hard to find proper scale and proportionate map.

Long story short

Vis is like negotiating with the devil even or those who has experience with it you may have a hard time to tackle it.

But if you manage to get it right it makes the map run very smooth and performance optimize.

 

@Kaskins 

Well here's a question for you Kaskins (and anyone else that wants to take a crack at this), the map in the video is cleary messed up. I haven't played this map on a live server dating back to about 2003. I downloaded it for an old GSA server, called Rebattle, along with many other maps for that server, and since then...these maps have been sitting in a folder either on my PC, or external hard drive. I never downloaded a new copy, or anything like that. So how does it work 100% back in 2003....gets stored on my PC for 15 years, and now when I play it, it's broken. Does that make sense? 

I'd love to fix it, or get it fixed, along with the other maps in this post. 

Share this post


Link to post
Share on other sites

Changed your computer has become, not your files. Updated graphics drivers perhaps lies your problem.

Share this post


Link to post
Share on other sites
On 8/9/2018 at 3:07 AM, trunkskgb said:

 

@Kaskins 

Well here's a question for you Kaskins (and anyone else that wants to take a crack at this), the map in the video is cleary messed up. I haven't played this map on a live server dating back to about 2003. I downloaded it for an old GSA server, called Rebattle, along with many other maps for that server, and since then...these maps have been sitting in a folder either on my PC, or external hard drive. I never downloaded a new copy, or anything like that. So how does it work 100% back in 2003....gets stored on my PC for 15 years, and now when I play it, it's broken. Does that make sense? 

I'd love to fix it, or get it fixed, along with the other maps in this post. 

 

Hey @trunkskgb

So you have to see when Renegade was first release it was so buggy and crashing was like a normal thing like bluehell when you 2 vehicles bump into each other + lag causes that. Now as TT progresses and issued fixes and clean up codes, some stuff starts to kick in.

  • ID Conflict ( Relatively easy to fix but before TT 4.0 came out you can play a map with a conflicted ID ) is something like if you have a preset with the same ID with another preset.
  • Scripts, some script might be missing from the map which dates from 2003, I do not know if the author use scripts or not at all, but if there are, it is a possibility there is a custom script.
  • Texture, not quite sure about it as I notice one time I had a texture in it but it was not displaying in the game. I cannot recall how I fix it. I think i saved it as dds.
  • Failed to load certain music/sound files.

So basically 15 years ago, Renegade was kinda buggy and messed up. The author made this map without knowing it will be broken down the road as during that time it works. So after TT issued fixes and check for some errors or critical issue regarding the map, the game will not launch due to some critical errors with the map which may result in a server crash or client crashing.

Like for example Ravine map earlier is crashing because the preset looking for the music file is missing, so the game crash and provide the errors msg.

But this is only on the Renegade side, you may also have to thing about your computer hardware and software like what @Raptor29aa mentioned. Although this is very unlikely and safe to say this is a rare case scenario becauses since majority can run renegade unless you decide to go 4k or beyond that resolution, someone told me his renegade crash at 4k resolution about 5 years ago.

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×